Форум Kunena 4.0.10 для Joomla 2.5 и 3.x

Очередной выпуск новой коммуникационной платформы для Joomla - КУНЕНА 4. На сегодня Кунена (компонент форума - или просто форум) является идеальным - форумом для cms Joomla. Это бесплатное и лучшее расширение которое полностью интегрируется в CMS Joomla и не требует никаких мостов и хаков движка.

 Разработчики знаменитого компонента Kunena выпустили новую стабильную версию Kunena 4.0.10 сокращенно [K 4.0.10] компонент по-прежнему как родное расширение для Joomla только на этот раз для Joomla 2.5 и Joomla 3.x. В этой версии многое изменилось, и как и любой другой выпуск Kunena - этот выпуск устраняет большинство обнаруженных проблем из предыдущих версий K 3.x и вносит множество улучшений, а также решены все проблемы, обнаруженные в ходе этапа разработки K.4.x.

Краткий обзор основных изменений в отличии от Kунена 2.0

Полный список всех изменений слишком большой, чтобы здесь его разместить, но их обзор приведен на официальном сайте Kunena.
Ключевыми элементами изменений новой версии (4) являются:

  • Переписан основной код компонента
    • Добавлена поддержка для Joomla 3.x
    • Удален весь код для поддержки старых версий Joomla 1.x
  • Добавлен новый установщик на базе AJAX
    • Значительно улучшающий процедуру установки и обновления
  • Новый Bootstrap движок для Joomla 2.5 и Joomla 3.x
  • Улучшена безопасность, защита прямого доступа к /component/kunena
  • Исправлены многие ошибки замеченные в версии Kунена 3.x и 4.x
 

Системные Требования Компонента Кунена-4

PHP: версия 5.3.1 или выше (>= 5.4.14 рекомендуется)

MySQL: версия 5.1 или выше (>= 5.5 рекомендуется)

Joomla! 2.5: версия 2.5.9 или выше (>= 2.5.11 рекомендуется)

Joomla! 3.0: версия 3.0.3 или выше (>= 3.0.3 рекомендуется)

Joomla! 3.1: версия 3.1.1 или выше (>= 3.1.1 рекомендуется)

max_execution_time >= 30

memory_limit >= 32M (>= 64M рекомендуется) - зависит от того, что еще установлено на сайте (расширения)

safe_mode = ВЫКЛ.

upload_max_filesize >= 3М

GD, DOM, JSON должны быть установлены

Kunena 3.x по прежнему имеет один установочный пакет для установки как в Joomla 2.5, так и Joomla 3.x. В компоненте Кунена 3.х используются современные функции определения ошибок в Joomla, процедура установки будет прервана с сообщением об ошибке, если Ваша система не отвечает минимальным требованиям.

Установка компонента, а так же его русификация.

Компонент Kunena устанавливается как обычное расширение, в принципе там нет ничего сложного. Единственное, что нужно отметить, это только то, что лучше всего первым делом установить языковый пакет (русификатор), который находится в архиве с компонентом.

К примеру, для русского языка - это будет файл из папки:

папка: Kunena 3.x Extensions
файл архива: pkg_kunena_v4.0.10_2015-11-16.zip
файл русского языка: com_kunena_ru-RU_v4.0.10.zip.

Устанавливать лучше всего только один язык из пакета, а не все языки сразу, поэтому в архиве дополнительно к английскому присутствует только русский язык. Вот и все, что можно отметить, русский язык установлен, теперь можно устанавливать сам компонент: pkg_kunena_v4.0.10_2016-02-18.zip

Процесс установки для Kunena 4.0.x похож на процесс установки который использовался в более ранних версиях. Там нет ничего сложного, а даже наоборот, все очень просто.

Обновление предыдущих версий 1.6 и 1.7.x до новой версии -
[К 4.x]

При обновлении тоже все просто, хотя важно отметить только то, что если Вы меняли шаблон или вносили какие то изменения в код шаблона Кунена, все это будет утеряно при обновлении до версии 3.x.

Сам процесс обновления происходит автоматическом режиме и на большинстве сайтов не занимает более двух минут, также при обновлении сохраняются все Ваши сообщения и настройки форума. В общем все, что было создано в предыдущей версии Kunena останется, за исключением изменений внесенных в код или шаблон Кунена.

Также очень важно понимать, что обновление до версии [K 4.x] не всегда проходит гладко, прежде чем обновляться, нужно внимательно изучить Ваш сайт на Joomla, потому что, большинство сайтов имеют множество других установленных расширений.

Эти другие Расширения для Joomla - особенно, если они старые и не обновлялись в течение длительного периода времени, то такие расширения могут вызвать проблемы при обновлении Kunena. Это никак не связано с тем, что Kunena является причиной этих проблем. Скорее, эта причина заключается в том, что Kunena использует новые и обновленные основные компоненты Joomla, которые могут быть причиной конфликтов с другими расширениями.

Обязательно делайте резервные копии перед обновлением компонента.

И еще один момент, так как Кунена 4.x не совместима с предыдущими версиями модулей и другими расширениями, разработанными для предыдущих версий Кунена, рекомендуется их отключить и сразу обновить после обновления компонента. Источник http://service-joomla.ru/komponenty/item/95-kunena-3x-forum-dlya-joomla.html

 

Скачать форум Kunena 4.0.10 для Joomla 2.5 и 3.x  можно по прямой ссылки ниже:

 

 

Администратор

Дорогие читатели, все ссылки рекламного характера будут удалены с комментариев

Другие материалы в этой категории: « Компонент ZOO для joomla 2.5/3.0

Добавить комментарий


Защитный код
Обновить

Популярные

Популярные

Подписаться на статьи